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Product Review  
 

Effective document retrieval from a Document Management System (DMS) requires accurate and thorough keyword 

indexing. Keywords contain information used to filter and locate documents, e.g. document date, account number and 

account holder. INFO-INDEX facilitates indexing by enabling users throughout an organization to create barcode index 

sheets via a single interface integrated directly with the DMS. Once printed, barcode sheets are placed in front of each 

document and routed for scanning. INFO-INDEX is most valuable when combined with Host Sync, which populates and 

synchronizes DMS document index data obtained from line of business systems.  
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Product Support 
Support for this product is available from PROFORMANCE. Contact a support specialist by either method listed below. 
 
Contact Information: 
 
Phone 
281-292-9000  (Monday-Friday, 8:00AM to 5:00PM CST) 
This phone number can also be used after hours to contact the On-Call support. 
 
Email 
support@pf-inc.com 
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Exploring the Workspace  
 

The Workspace Layout 
 

INFO-INDEX provides an integrated single-window workspace layout comprised of the following elements: 

 

1. Available document types 

2. Selected document types 

3. Keyword value input 

4. Menu bar 

5. Quick action toolbar 

6. Selection buttons 

7. Status bar 

 

1. Available document types      2. Selected document types    3. Keyword value input 

4. Menu bar          5. Quick action toolbar 

 

 
 

 6. Selection buttons       7. Status bar 
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Available Document Types 
This element contains DMS document types assigned to a scan queue. This list can be organized by Autofill 

Keyword Sets, Custom Templates, Document Type Groups, Scan Queues and All Scan Document Types.  

 

NOTE: Document types presented to users in this list are limited to those defined by DMS user group security. 

 

 

To select a single document type: 

 Double-click the document type row (or)  

 Click the document type row then click the select button   

To select multiple document types: 

 Click the first document type row, hold the Shift key down, then double-click the last document type row 

(or) 

 Click the first document type row, hold the Shift key down, click the last document type row then click the 

select button (or) 

 Click a document type row, while holding the Ctrl key down, click additional document type rows then 

click the select button 

To select an entire grouping of document types: 

 Click the group row indicated by a plus or minus icon then click the select group button  

Selected Document Types 
As document types are selected, they appear in this list along with the number of copies to print. The default 

number of copies is one. Barcode cover sheets will be printed for document types in the order they appear in this 

list. 
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To change the number of print copies: 

 Click the cell in the Copies column you want to change 

 The field is opened for edit and a number spin button appears to the right 

 Type the number of copies you want to print (or) 

 Use the up/down arrows to change the value 

To remove a single document type: 

 Double-click the document type row (or) 

 Click the document type row then click the remove button   

To remove multiple document types: 

 Click the first document type row, hold the Shift key down, then double-click the last document type row 

(or) 

 Click the first document type row, hold the Shift key down, click the last document type row then click the 

remove button (or) 

 Click a document type row, while holding the Ctrl key down, click additional document type rows then 

click the remove button 

To remove all selected document types: 

 Click the Remove Selections toolbar button (or)  

 Click File > View > Remove Selections from the menu bar (or) 

 Click the remove all button  

To change the print order: 

 Click a document type row to select 

 Click the move up button (or)  

 Click the move down button  

Keyword Value Input 
As document types are selected, keywords assigned to each appear in this list. Keywords are grouped by Autofill 

Keyword Sets (one group per autofill keyword set), System Keywords, Security Keywords and Document 

Keywords. This element allows input of keyword values for placement on barcode cover sheets. Keyword names 

in bold type indicate they are required by the DMS. 

 

NOTE: Keyword values are not required to produce “Document Type-only” barcode sheets. 
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Autofill Keywords 
If the document type is assigned to an autofill, the entire autofill keyword set is displayed. The primary keyword 

is open for input, while all secondary keywords remain read-only. If the primary keyword value entered appears 

in the DMS autofill table, the secondary keyword values are automatically displayed as a confirmation. Primary 

keyword values are usually required. Secondary keyword values are usually not required. 

System Keywords 
All document types will contain the system keyword Document Date. Document Date is usually not entered, but 

is optional. 

Security Keywords 
DMS security keywords will be grouped separately to allow user input of values, e.g. Institution ID. If Institution 

ID is a secondary keyword in an autofill, but the autofill table does not yet contain an entry for the primary 

keyword value, documents can still be scanned and viewed by the appropriate DMS users. Security keyword values 

are usually required if the primary keyword value is not present in the DMS autofill table. 

Document Keywords 
All other document type keywords appear in this group. These keywords are usually entered if available or 

applicable. 

Entering Keyword Values 
Input is allowed for a keyword only if the row is not shaded. Input is validated using the keyword type definitions 

from the DMS. To navigate down the list, press TAB, ENTER or use the DOWN arrow. To navigate up the list, press 

Shift+TAB, Shift+ENTER or use the UP arrow. Values may be keyed directly into the cell or selected from a lookup 

dialog. When the input field has focus, a lookup button appears as either a down arrow for dates or an ellipse for 

other lookup data types. Clicking the lookup button invokes the appropriate lookup dialog.  

Autofill Keyword Lookup 
When performing a lookup on the primary key of an autofill keyword set, the lookup dialog will present data 

directly from its DMS autofill keyword set table.  
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Using the Lookup Autofill Keyword Values dialog: 

 Select the Search Keyword from the dropdown box (default is primary keyword) 

 Select how you want to search from the dropdown box to the right of the search keyword (default is 

Contains) 

 Enter the Search Value and click the Find button 

 Double-click your selection from the results grid (or) 

 Click your selection from the results grid and click OK 

 

NOTE: If the search value is left blank and the Find button is clicked, all values in the DMS autofill keyword set 

table are displayed. 

 

Document Keyword Lookup 
When performing a lookup on a document keyword, the lookup dialog will present data directly from its DMS 

keyword table containing all keyword values stored. Lookups are available for all document keywords with the 

exception of dates, currency and floating point numbers.  

 

 

Using the Lookup Keyword Values dialog: 

 Select how you want to search from the dropdown box to the right of the search keyword (default is 

Contains) 

 Enter the Search Value and click the Find button 
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 Double-click your selection from the results grid (or) 

 Click your selection from the results grid and click OK 

 

NOTE: If the search value is left blank and the Find button is clicked, all values in the DMS keyword table are 

displayed. 

Date Selector 
For keywords defined as dates in the DMS, a date popup appears when the lookup button is clicked.  

 

 

 To key a date: 

 Click the Value cell 

 Type the month followed by a “/”, the day followed by a “/” and the 2 or 4 digit year 

To select a date: 

 Click the Value cell dropdown button to display the date selector 

 Click a date from the current month (or) 

  Use the arrow buttons to navigate the calendar to prior or future months and click a date 

To clear a date: 

 Click the Value cell dropdown button to display the date selector 

 Click the Clear button 

 

NOTE: When using the date selector, you must click on a date before it will be assigned to the keyword value. 

Clearing Keyword Values 
Keyword values may be cleared one at a time or all in one step. See the previous section for clearing date values. 

To clear one keyword value: 

 Click the Value cell 

 Click Ctrl+A to select the contents  

 Press Delete 

To clear all keyword values: 

 Click the Clear Values toolbar button (or)  
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 Click File > View > Clear Values from the menu bar  

Using F2 Edit Mode 
F2 Edit Mode opens secondary keyword values of an autofill keyword set for input. Use the F2 key or select View 

> Edit All Keywords to toggle this mode on and off. The status bar indicates whether this mode is active. Secondary 

keyword values are usually not required when bar-coding; however, if Host Sync is not deployed and the host 

entry does not exist in the autofill keyword set table, they should be entered using this mode. 

 

The status bar will indicate if this feature is active. 

 

Using F6 to Add Another Keyword Value 
Additional instances of numeric and alphanumeric keyword types may be added to barcode cover sheets by using 

the F6 key. 

To add another keyword value instance: 

 Place the cursor inside a keyword field containing a value and press F6 

To delete an unwanted keyword value instance: 

 Simply clear the keyword value for any instance you no longer wish to print 

 

NOTE: This feature is only available on numeric and alphanumeric keyword types. It cannot be used for dates, 

currency or floating point keyword types. 

 

Using F9 Reuse Mode 
Keyword values may be retained and reused for new barcode cover sheets. Use the F9 key or selecting View > 

Reuse Keyword Values to toggle this mode on and off. The status bar indicates whether this mode is active. When 

active, an additional column of checkboxes is visible allowing selection of keyword values to retain for reuse. Once 

added to the queue or printed, the selected keyword value will pre-populate the next time a document type 

selected contains the keyword. 

 

 
 

The status bar will indicate if this feature is active. 

 



 

13 

 

To activate F9 Reuse Mode (if inactive): 

 Press F9 (or) click View > Reuse Keyword Values  

To select and populate Reused Keyword Values: 

 Enter keyword values and check each keyword to reuse  

 Click Add to Queue (or) Click Print Barcodes 

To clear selected Reused Keyword Values: 

 Click Tools > Reused Keyword Values  

 Check each keyword to remove and click OK 

To clear all Reused Keyword Values (if active): 

 Press F9 (or) click View > Reuse Keyword Values  
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Using INFO-INDEX 

Generating Barcode Sheets 
There are two ways to generate barcode sheets. Barcode sheets for the current selections can be printed 
immediately or they can be added to a queue and printed later prior to closing INFO-INDEX. 

Printing Current Selections 
Barcode sheets for the current selections may be sent directly to the printer. This option is available as long as the 

queue is empty. If the queue is not empty, you must add the current selections to the queue before they can be 

printed. After document type selections are printed, they are removed from the selected list unless the Lock 

selections checkbox is activated. 

To print current selections: 

 Click the Print Barcodes button located on the toolbar (or) 

 Click File > Print Barcodes from the main menu (or) 

 Press Ctrl+P 

Adding Current Selections to the Queue 
Current selections may be added to the queue to be printed later. The status bar displays a counter indicating the 

number of selections currently in the queue. After the document type selections are added to the queue, they will 

be removed from the selected list unless the Lock selections checkbox is activated. 

 

NOTE: Queued selections must be printed before closing the application or they will be discarded. You will be 

warned if this situation occurs. 

To add current selections to the queue: 

 Click the Add to Queue button located on the toolbar (or) 

 Click File > Add to Queue from the main menu (or) 

 Press Ctrl+S 

Previewing Queued Selections 
Barcode sheets for selections in the queue may be previewed before printing.  

To preview selections in the queue: 

 Click the Preview Barcodes button located on the toolbar (or) 

 Click File > Preview Barcodes from the main menu  
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Printing Queued Selections 
Barcode sheets for the current selections may be printed immediately. The queue is deleted following the print 

process.  

To print all selections from the queue: 

 Click the Print Barcodes button located on the toolbar (or) 

 Click File > Print Barcodes from the main menu (or) 

 Press Ctrl+P 

Deleting the Queue 
All selections may be deleted from the queue. Individual barcode sheets cannot be deleted.  

To delete all selections from the queue: 

 Click the Delete Queue button located on the toolbar (or) 

 Click File > Delete Queue from the main menu 

Examples  
The following examples illustrate two common ways to use INFO-INDEX. 

Preparing Multiple Barcode Sheets for One Customer 
Three documents are to be archived for customer Joe Armstrong. These documents are Address Change, Articles 

of Incorporation and W-2. 

Steps: 

 Click the Autofill Keyword Sets navigation bar  

 Double-click the Contact Autofill to expand the list 

 Double-click CIF Address Change to add 

 Double-click CIF Articles of Incorporation to add 

 Double-click CIF W-2 s to add 
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 We do not know the customer’s CIF number, but we do know the SSN 

 Click the CIF keyword value input field 

 Click the Edit Button to the right 

 

 
 

 Change the Search Keyword dropdown to SSN 

 Enter Joe Armstrong’s SSN in the Search Value, click Find, then click OK 
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 Keyword values from the CIF Autofill table are populated 

 

 
 

 Click the Print Barcodes toolbar button or press Ctrl+P  

 Insert each barcode sheet in front of their corresponding document and scan them into the DMS 

Preparing Single Barcode Sheets for Multiple Customers 
A stack of Address Change forms are to be archived. Each form is for a different customer. This example illustrates 

INFO-INDEX’s capability for rapid user input. 

Steps: 

 Click the Autofill Keyword Sets navigation bar  

 Double-click the Contact Autofill to expand the list 

 Double-click CIF Address Change to add 

 Click to check Lock selections 

 
 



 

18 

 

 Click the CIF keyword value input field 

 For each Address Change form, type the CIF number and press Ctrl+S to add to the queue 

 Click the Remove Selections toolbar button to unlock selections and allow printing 

 When finished, press Ctrl+P to print barcode sheets 

 Insert each barcode sheet in front of their corresponding document and scan them into the DMS 
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Program Settings 

Custom Templates 
Custom templates are a one-dimensional logical grouping of available document types designed for quick access 
of repetitively used sets of document types, e.g. Car Loan, Boat Loan and Mobile Home Loan. Document types 
presented to users in custom templates are limited to those defined by DMS user group security. 
 

NOTE: Administration of custom templates requires the Setup Barcode Template client action. 

 
From the main menu, click Tools > Template Maintenance. 
 

 

To add a custom template: 

 Click the Add… button  

 Type the Template Name and click OK 

 Select the appropriate document types from the available list on the left 

 When finished, click OK 

To rename a custom template: 

 Click the Template to rename and click Rename… (or) 

 Double-click the Template Name 

 Type the new Template Name and click OK 

To delete a custom template: 

 Click the Template to remove and click Delete 

 Click Yes to confirm deletion 

To add or remove document types: 

 Click the Template to change and click Document Types… 

 Select the appropriate document types from the available list on the left to add 

 Remove the appropriate document types from the selected list on the right to remove 

 When finished, click OK 
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Batch Barcode Processing 
Barcodes can be printed in a batch-mode based on input supplied from a line of business system stored in a text 
file. A batch process can be executed from a command line, from inside the client application or as an 
unattended scheduled event.  
 

NOTE: Administration of batch barcode processing requires the Setup Barcode Batch client action. 

 
From the main menu, click > Batch Process Maintenance. 
 

 

To add a batch process: 

 Click the Add… button  

 Type the Batch Process Name and click OK 

 Enter the Batch Process Settings and click OK 

 Select keywords from the available list that matches the input file definition and click OK 

 Select keywords from the available list to display in the barcode sheet header and click OK 

To rename a batch process: 

 Click the Process to rename and click Rename… (or) 

 Double-click the Process Name 

 Type the new Process Name and click OK 

To delete a batch process: 

 Click the Process to remove and click Delete 

 Click Yes to confirm deletion 

To modify batch process settings: 

 Click the Process to modify and click Settings… 

 Update the Batch Process Settings and click OK 

To add or remove file definition keywords: 

 Click the Process to modify and click Keywords… 
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 Add or remove keywords to matches the input file definition and click OK 

To add or remove header keywords: 

 Click the Process to modify and click Header… 

 Add or remove keywords to display in the barcode sheet header and click OK 

To preview a batch process: 

 Click the Process to preview and click Preview Batch… 

To print a batch process: 

 Click the Process to print and click Print Batch… 

Settings 
This dialog defines the batch process settings. These settings apply to the entire batch. All records in the batch 

process file must have the same field delimiters and separators. 

 

Delimiter Character – The character that surrounds each field in the batch process file (optional) 

Separator Character – The character that separates each field in the batch process file 

Document Type – The DMS document type associated with each entry in the batch process file 

Batch Process File – The full path and filename of the batch process file  

Printer – The printer to which barcode sheets from this batch process will be printed 
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Keywords 
This dialog defines the record layout of the batch process file. Select the DMS keywords from the available list in 

the order they appear in the batch process file. Select ">> Ignore Field" for fields that do not have a corresponding 

keyword or that you simply want to ignore.  

 

NOTE: The number of selected keywords must match each record in the batch process file. 

 

 
 

 

Sample batch process file matching the keyword selections above: 
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Header 
This dialog identifies keyword values that appear in the barcode sheet header. Both the keyword name and value 

are printed. More than one keyword may be selected, but depending on the length of the labels and values, may 

not fit entirely on the page. 

 

 
 

Sample barcode sheet matching the header selections above: 

 
 

NOTE: Barcode sheets printed from a batch process will print with the batch process name as the username in the 

barcode sheet header. 

 

  



 

24 

 

Preview Batch 
Batch processes may be previewed for testing purposes to ensure that all settings are working as expected. If an 

error is encountered, a message will appear as a link in the Message column, otherwise the barcode sheets will 

be presented in the print preview dialog.  
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Print Batch 
Batch processes may be printed directly from the application. If an error is encountered, a message will appear as 

a link in the Message column, otherwise barcode sheets will print directly to the printer specified in the batch 

process settings.  
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Command Line Processing 
Batch processes can be executed from a command line. This command line may be placed in a batch file and 

scheduled as an unattended event. Following execution, the batch process status window will automatically close 

after 10 seconds. 

 

 

Command Syntax:   

 <program_name> <options> 

Available Options: 

 un="username" – Valid INFO-INDEX username 

 pw="password" – Password for username specified in username option 

 process="process name" – Batch process to execute 

Sample command to execute one batch process: 

 INFO-INDEX.exe un="Administrator" pw="xxx" process="AP Invoices" 

Sample command to execute two batch processes: 

 INFO-INDEX.exe un="jadams" pw="xxx" process="ap invoices|hr applications"   

 

NOTE: Command line options are NOT case sensitive, MUST be separated by a space and may appear in any order. 
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User Options 
Each user has control of selected program settings. These preferences are specific to each workstation and user 
combination. 

To access the user options dialog: 

 Click Tools > User Options… from the main menu 

 Make desired changes and click OK 

 

 

Startup Group 
The Startup Group preference determines the view of the available list presented when INFO-INDEX starts.  

Available selections: 

 Autofill Keyword Sets 

 Custom Templates 

 Document Type Groups 

 Scan Queues (initial default) 

 All Scan Document Types 

Color Scheme 
The Color Scheme preference determines the user interface colors and style.  

Default Printer 
Unless changed, INFO-INDEX prints to the Windows default printer. The Default Printer preference allows another 

printer to be designated as the default INFO-INDEX printer. 

Select Threshold 
The Select Threshold specifies the number of document types that can be selected at one time before a warning 

message is presented to the user. The threshold is designed to prevent users from inadvertently selecting all 
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document types at one time, since that process may take some time to execute. This preference can be set from 

100 to 2000 in increments of 100. The default is 100. 

Show Toolbar Text 
If checked, the Show Toolbar Text preference allows the toolbar button description to display along with the icon. 

If unchecked, only the icon will display.  

Restore Defaults 
Click the Restore Defaults button to set all user preferences back to the factory defaults. 

 

 


